Choice forum spellcheck

The built-in spell checker for topic posting on this forum speaks American: …ise becomes …ize and …our becomes …or Would it be possible to change it to Oz English?


Hi @syncretic,

The forum uses your browser setting to determine the spell checking. If you need any help with this, let me know which browser you are using and I can help out.


Thanks …20


irregardless … heh heh. I’m stuck with American … colour … valour … neighbour … all spelled incorrectly, but irregardless is fine according to the American spell check … the world truly is doomed …


Shoot, y’all canna be too down wit’ dem apples!

Have you checked what language default your operating system is using? If you can’t find a browser setting, it’ll be using the OS setting.

1 Like

Warning Will Robinson, the last time I tried to change the OS language (if anyone gets tempted) I ended up reloading the whole lot from an image backup. That change confused many parts of the OS as well as applications beyond their ability to function properly. Some things still struggle if you set the font to a non-default or non-standard size.

Microsoft as well as many applications developers live in the world of US English (eg American) and all users have great eye sight, and everything else is an add-on make do although they seem to be getting better at it all the time.

Putting our hardship into perspective I empathise with those using other languages and other character sets.

In Chrome:

  • Go to Preferences & scroll to the bottom of the page
  • Expand out the Advanced section
  • Keep scrolling down until you find the Languages section
  • Click on the down arrow on the right to open up the section
  • You’ll see a list of languages and English (United States) will be at the top
  • On the three dots on the right side, left click with your mouse and select the option to move down/up according to your preferences
  • Close everything up and head back to your page

You might need to close the page up that you are editing and reopen it after your language settings have been changed.


My home system works fine :slight_smile: I know why it happens at work - we configure it that way, and I have the access to change anything I want, but that would be a misuse of privileges in an environment that is not exactly tolerant of ‘exceptions’.

1 Like

Many readers will have seen this before. I had to search - it is something I first encountered a few years BI (Before Internet).

(I also made a few changes to the version I found, which lacked one or two ‘options’ and used at least one New Zealand pronunciation!)

Eye halve a spelling chequer
It came with my pea sea
It plainly marques four my revue
Miss steaks eye can knot sea.

Eye strike a quay and tie per word
And weight four it two say
Weather eye am wrong oar write
It shows me strait a weigh.

As soon as a mist ache is maid
It nose bee fore two long
And eye can put the error rite
Its rare lea ever wrong.

I’ve run this poem threw it
I’m shore your pleased two no
Its letter perfect in it’s weigh
My chequer tolled me sew.

(Sauce unknown)


Setting a good example for us all by having a backup on hand. Always remember, 3-2-1.

1 Like

As a side note can you get your I.T. department to replace the American spell checker in your pop up chat with Australian please? It’s disconcerting to have Choice wanting me to spell favourite “favorite” or night “nite” every time lol.


Just moving this over here @obbigttam :slight_smile: The site uses your browser settings to manage this, if you like I can assist with changing this, just let me know which one you are using.


I’ve just added English and made it default/top of the list in my Firefox dictionaries, and restarted FF, but the spell checker still thinks favorite is a word, and favourite is not!


Did you start a text box (eg a reply box will work fine), right click in it and select the language?


errm, no, but I did this time :slight_smile:


On my iPhone I found that I’m in charge
of the ‘English’ used : it includes NZ,
India, Canada, etc.,

From: Setting>General>Language&Region>
iPhone language English >English…
(Multiple choices of English.)

As I have chosen Au English, my phone underlines in red ‘Color’ and replaces it with ‘Colour’.


The iPad is equally adept. It steadfastly refuses common words found in everyday Australian use if does not believe they belong. Eg kekap manis, is the latest of a long line of exceptions. Nothing to do with how it interprets colour of course.:flushed:

Usually it gives up after the second attempt to put the spelling back to how you want it. Or you can select it as first spelt from the list above the touch keyboard!

1 Like

That old Aussie standby is “kecap manis”, no?

‘irregardless’ of that … :rofl:


An article regarding some of the quirks of the English language.