Having trouble accessing a service through an app?

Hi everyone,

I wanted to ask if you’ve had trouble accessing a service that you need to use because of a tricky app. Apps should make things simpler, but sometimes they make things harder!

The other night I was parking on a University campus. When I went to pay for parking I noticed that none of the parking machines were available for use. Instead, we were directed to download a parking app.

Some of the issues that I see with this app:

  • you have to create an account to sign up, and provide a lot of unnecessary information including number plate, email, names, credit card details which makes the process really long
  • we did not know the hourly rates until AFTER we ‘began’ our parking session
  • we had to begin and end our parking session on the app. I don’t know what would have happened if the phone had gone flat
  • I think that this app is quite inaccessible and the parking area provided no alternatives to using it
  • Additionally, people who do not have a working smartphone may not be able to access parking

What do you think? Have you had any experiences with tricky apps that you want to share?


Not just the long process of getting the App used but the data you are handing over to use the App in your parking circumstances is way beyond the needed and even why is an App needed when you could stick a ticket in your car that hides most of your personal and what should be private info (I understand that no provision was made for tickets but they should have been). A security risk, and what privacy policy do they ascribe to, where is your data stored, how is it stored, who has access to it, what authorisations did you have to give the App so it would work, what will the data you provide be used for among some of the concerns I have.

The App is way beyond intrusive, it is just a huge risk.


I have 3 WEMO devices that have an app to control them, but since a firmware update a few months ago, 2 of them have been rendered useless, unable to be used. One of them almost caused the death of 200 Rainbow Trout when it stopped working. Fortunately I only lost a few, but most of them were very unwell for a day or 2.
Since the supposed update I can’t get the devices to show up in the devices list, although I can apparently connect to them as directed in the adding a new device instructions, but after dozens of attempts and factory restores, they are still useless pieces of electronic junk.
Installing a new version of the app made no difference.


Not a firewall or data blocking software (eg browser privacy tool) issue or App permission that needs changing? Probably not but just in case…


I don’t think so, the firmware update appears to be the problem, as it took all night, and I have no idea if it ever finished. They usually took many hours on previous updates, which is a bit odd, since they can’t have been that big a file. Plus, one of them still works, which didn’t have the update at the same time.
I don’t run any firewall software on my phone anyway- don’t use BT and only ever use wifi when at home.


Redo the Firmware update if one can be forced to occur?? The manufacturer maybe able to advise how to do so.


I’ve tried! It appears you can’t do it when the devices don’t show up in the list.


Can they be removed and plugged into say a PC to create a hard wired connection? I suggest contacting the Manufacturers of the devices as to how it can be done this way if possible. Firmware over wifi can be very hit and miss as to success.


Unfortunately no, wifi is the only connection method, and they are just plugged into a power point, from where they are supposed to switch things on and off.

I did try emailing Belkin, but it was returned, they no longer offer email support. I’ll have to try phone or live chat help next, although I’m not really confident that will do much, based on past experiences with phone help and live chat, which generally seems to be outsourced and not very helpful.


Can you give me the model numbers and I will try and find some answers for you.


Thanks Graham, they are both Belkin WEMO switch, model F7CO27au


I have few apps, but the ones I do use have limitations where there is no internet / mobile access. There’s no mobile signal on our property, but I do have WiFi / satellite at the house. Some apps must have a mobile signal to work, some will use the WiFi, I suspect some object to the wait time for the data to travel up & back to the satellite or when it is overcast (it goes out when it rains).

I was encouraged to download the Suncorp App but could never get it to work, couldn’t even register the password, fortunately I can do my business by phone.

I do a bit of Citizen Science, The Butterfly App won’t complete a sighting. The FrogID app can only hold one recording, so I have to get back to the house to submit and walk back to get the next recording. It is Frog Week, so I walked the 1.6km to the back dam through rough tracks & bushland, in the dark, to get one recording and trek back to submit. Unfortunately when I recorded last night there must have been an update pending for species so it stalled, even when I got home, and I had to delete the recording and restart the App to walk back & do again, successfully.

Back Country Navigator - which I paid for and use for mapping and weed locations - it’s actually a hiking app - works wonderfully without internet/mobile signal. Download the topo maps and it uses the GPS in the smart phone to record your walk, notes and photos. A file can be generated and overlaid on Google Maps. An example of a good app for non-connected areas.


I use the FrogID App and also Frogs of Australia.
Frog ID keeps each recording. I access them by using the ‘Profile’ button. This brings up a bar near the bottom of the screen titled ‘All Activity’ with a count and arrow on the hrs. Tap and it displays a list of recordings by date and time etc. I assume you can select as necessary to register each one as required?


@mark_m I use Profile too (to look at what I have submitted etc) but I find the problem is when I have to Submit (or even load the suggested species to choose from) can only be done with internet access. When I try to record another, it asks if I want to delete the previous record. I’ve been doing it since 2017.


An app that is horrendous to use is the Goverment Portal which is the home to Centrelink, Medicare, NDIS, etc.

They are the epitome of bad design. I can point to one bit that they got right: the email section actually works well. The rest is worthy of an anti-award.

It would seem that they tasked the back room IT guys (the ones who are not allowed to interact with clients, and never see the light of day) and got them to knock something up when they had spare time.

Unfortunately, that first iteration was never shown to stakeholders, or improved before it went into production. Consequently it is antagonistic to clients actually using it.


Richmond Avenal* perhaps?

*You’d need to have watched The IT Crowd to understand :slight_smile:


:laughing: I didn’t watch the IT Crowd, but had more than enough first hand experience with such IT people who worked with and for me.


I have a Smartphone but NEVER download any apps due to the Privacy invasion and increased hacking risk to my phone.

To be forced to download an app in order to park your car is both an infringement on ones personal rights and very dictatorial in that it is impossible to use these parks unless you have the phone and are happy to download this app.



Is that the only option. I thought you could still pay at a kiosk style machine via card or cash?

1 Like

This app takes the cake:

By March 2020 you HAVE to use it if you want to logon to the Govt Business Portal.

Apart form the fact that at the moment it has a 1.7 out of 5 rating with most reviews stating they can’t even get it to run, I can’t even load it onto my phone as it requires Android 7 and my phone is Android 6.

I’m certainly not going to buy a new phone just so I can run a govt app. I’ve given feedback, but I suspect they aren’t going to support less than Android 7.

Lots of valid complaints in the reviews, such as workplaces with a ‘no phone’ policy