GoPro Disappointment

We bought a GoPro Hero 3+ Black in 2014 and it has been one of the most disappointing technology products we have ever owned.
I have never been able to get it to continuously record. It will run for some time and then stop recording and display a “Full” message.
I now set if for maximum time recording but even that is not satisfactory.
Several weeks ago, I was driving into the Cairns CBD in the right-hand lane when an idiot in a large truck entered the road ahead of me and drove in the left-hand lane.
I caught up to the truck at the intersection when we both turned left, but as I started passing it, the truck’s indicator came on and the driver immediately started to enter my lane.
I locked the horn on and the idiot pulled back into the left lane in the nick of time.
On the way home, I stopped at our local shopping centre, and when I left, the GoPro beeped to alert me that the memory was full.
When I got home I tried to download the video clip of the truck incident so as to email it to the company but the clip was not there. The clips before and after it were there up to when the memory was full. It had either failed to record it or had deleted it.
In another incident, when we were driving to SEQ last December, we took the bypass road at Townsville. I noticed a white SS Commodore parked on the left side of the road in the 80 Km zone.
As we were passing by, the vehicle suddenly started to do a U turn across the double white line road without even indicating. My wife screamed and I locked the horn down. It must have almost touched the side of our vehicle. I noticed a green P sign on the left side of the windscreen.
I believe that it was an unmarked police vehicle and I was going to get a registration search done but I could not read the number plate.
When we originally bought it, I tried to use the remote control feature with my HTC Desire 610 mobile phone but it would not work. I contacted GoPro and this was their reply.

“Update for Case #1334025 - “Can’t connect phone to WiFI”
Hi Peter,

Sorry about the issues with connecting you GoPro to your HTC Desire. Unfortunately that model of phone is not entirely compatible with our app. We try our best to cover every platform of android phone, but due to the vast number of devices that run android it is hard to make an app that is completely compatible with all android hardware.
You can test other options to be sure by connecting your camera to another device such as a tablet or other phone. Also ensure that your phones WiFi is on and you are selecting the correct device.

Let us know how it goes and we are sorry for the inconvenience.

Many Thanks,
Logan N.
GoPro Support”

Other people have dash cams which can record when someone approaches the vehicle when it is parked and can capture things such as number plates without being directly behind and close to the vevicle.
Very disappointed. It is no “Hero” in my opinion.


I used to use a GoPro Hero3 White as a dashcam. It could supposedly handle a 64GB SD card, but proved unreliable with the one I tried. A 32GB card worked OK.

Video tended to fill the card too quickly, so I set mine up to take a high-resolution image every second. Things like numberplates showed up much better in stills than video.

I’ve had no difficulty connecting the GoPro via WiFi to 'phones from Huawei and ZTE. The latter is Android 5.0.2. Not sure about the Huawei.


I have 4 Gopros and dont have any issues with any of them.

With gopros you can set it up as a dash cam and when the memory is full it will start deleting the old videos so you always have the current videos


I only use it as a dash cam, or at least try to.

I set it to record 1080p video as an endless loop , but regardless of whether I set it to “MAX” or “240 min”, it continues to fill up the memory and stop working.

1 Like

@Fred123 There might be something part way down in this support thread that helps you sort it. See users bv221 and blakes regarding the DFLT setting. Could be something else, but.


Thanks for your help.
I read the articles and the manual again but it is not doing what it should do.
I have downloaded and installed the firmware update from the GoPro website and will see if it makes any difference.
I am not 100% sure if the update installed correctly as I neither saw it displaying any messages about updating itself when I turned it back on but I also did not see any error messages.
It might be because I have it set to One Button recording and it immediately starts recording when I press the power button. Perhaps it would have displayed an updating itself message after the first press if I had it set for 2 presses to start recording.