Complaint about this webpage

I get a regular email from Choice Community, with a list of new posts. Very handy. I then find a post I am interested in, so click on it.
I get a blank page that asks me to join the community.

I think, as I have logged in earlier, it should open on the post I want to see, without me having to log in again, but at the very least, it should give me the opportunity to log in. It seems to presume that I am a new person and the only way I can log in is to close that page and open it again. I then have to go searching for the post I want to read as it seems to open in the beginning.
I have to be honest, half the time I just forget the whole thing, too complicated and time consuming
Also, once logged in, I get these cryptic numbers up the top. I haven’t tried today, but I have tried it previously and it didn’t open unread posts (which I presumed it would do, it did something weird that made no sense.

For starters, as you can see, it is still “inviting” me to join, even though I am now definitely logged in. If I hover over the C up top, it shows my user name

P.S., I have now clicked on the two #1s up the top. They both seem to show the same list

but I have no idea what to do with that list. Seems to be I HAVE read everything on that list.
As it happens, the reason I came here today is to read the post about Costco Homebrands, which I have not read before - as you can see, it is not listed here
I have now tried everything I can think of, mamaged to get rid of one of the numbers but this second one willl not go away. What does it mean?
I have clicked on everything, different places tell me I have 2 unread messages, so I click on that - nothing changes!

1 Like

I have the same problem. For months now I always have 1 unread notification, and 1 unread message, and it seems to treat me as if I am a non subscriber and should join Choice Community. No matter how many times I re-read the notification and message it just never goes back to zero. Why is this so?
Its no big deal though, as now I just ignore it, but seeing as someone else has the same issue it seems there is a bug in the software that needs investigation.
I would expect that when I receive an email from Choice Community that I should automatically be logged in when I click on say “New Subject or Posting” since the email knows how many new issues I haven’t read yet, and the numbers are only applicable to my account.


Hi @csutak40 / @Airsie,

Thanks for the feedback on our forum, we appreciate you taking the time to provide this info. We’ll review it in detail and look at ways we can improve the experiences you have mentioned. I might also be able to help out with some tips in the meantime as well that will hopefully make using the forum a smoother experience.

Depending on your browser settings, you shouldn’t have to log in each time if you are using the same device. Try clearing your browser history including cookies, and make sure you ‘allow local data’ from this site (Chrome pictured below, this setting may look different depending on the browser you are using). This should keep you logged in. If you don’t want to change your settings, you could also get your browser to ‘remember the password’ so that logging in is at least a lot quicker.

I understand what you mean about the ‘Join now’ message being confusing. We’ll have to have a look at some technical solutions to see if we can automatically remove it after a certain period of time. In the meantime, if you close the message using the blue ‘X’ button on the left once you have logged in, it shouldn’t reappear.

Sorry for the confusion with the numbers at the top. The green one indicates a private message, and I can see from your screen grab that in this case it’s a ‘Welcome to CHOICE.Community’ note. If you click on the text or mail envelope icon, it will take you to the private message and remove the notification (you can see the item turn yellow when you hover over it with your mouse, pic below). The blue notifications are for when somebody reacts or responds to a topic you have contributed in. Clicking the text will take you to the thread and will remove the notification as well.

Hope this helps, and thanks once again for the feedback!

Hi Brendan,

I recently changed my password. The new one had an ! and a * and the “checker” seemed happy. It appears the checker only counts characters not validates them, because when I tried to use the password it was not accepted to login. Once I changed it back to one having only alphanumerics, no worries.

You might have a word about special characters with those responsible for passwords.

Cheers, Phil

1 Like

Thanks @PhilT, I’ll flag this with our site developers :+1:

1 Like