CHOICE membership

Chromecast

I’ve had the Goodle Chromecast for a few months, and it worked perfectly until recently. However it has now stopped working. I’ve done everything possible to get it restarted, it only shows the ambient mode on my iPhone. I’m wondering whether to get a new one, delete and re-download the Google Home app, or what!! Ay help would be appreciated.

By the way, I’ve tried posting this on the Choice Community but wasn’t successful Not sure what I’m doing wrong…

Clea

3 Likes

You are on the Choice Community and this post was successful.

Have you tried unconnecting and then reconnecting to it? Google Support also suggest the following as well…

  1. Reboot your Chromecast.
  2. Unplug your router and plug it back in.
  3. Factory Reset your Chromecast.
  4. Contact support.

Also there are reports that if an iPhone has been updated to OS13, it won’t find the Google Chromecast wifi after the upgrade. Some users have found this works after upgrading to OS13…before doing a factory reset is to sign/log out of the apps used with Chromecast and then re-sign/log in.

7 Likes

It seems to have eventually sorted itself out, after several frustrating attempts! And yes, I had updated my iPhone so maybe that’s what it was…

2 Likes

We are pleased it is all working again.

1 Like